ECSqlInsertResult Class
The result of an ECSQL INSERT statement as returned from ECSqlStatement.stepForInsert.
If the step was successful, the ECSqlInsertResult contains DbResult.BE_SQLITE_DONE and the ECInstanceId of the newly created instance. In case of failure it contains the DbResult error code.
Insert statements can be used with ECDb only, not with IModelDb.
Methods
Name | Description | |
---|---|---|
constructor(status: DbResult, id?: string): ECSqlInsertResult |
Properties
Name | Type | Description | |
---|---|---|---|
id | undefined | string | ||
status | DbResult |
Defined in
- backend/src/ECSqlStatement.ts Line 26
Last Updated: 20 June, 2023