ECSqlBinder Class
Binds a value to an ECSQL parameter.
See also:
Methods
Name | Description | |
---|---|---|
addArrayElement(): ECSqlBinder | Adds a new array element to the array parameter and returns the binder for the new array element | |
bind(val: any): void | Binds the specified value to the ECSQL parameter. | |
bindArray(val: any[]): void | Binds an array value to the ECSQL parameter. | |
bindBlob(blob: string | Uint8Array | ArrayBuffer | SharedArrayBuffer): void | Binds a BLOB value to the ECSQL parameter. | |
bindBoolean(val: boolean): void | Binds a boolean value to the ECSQL parameter. | |
bindDateTime(isoDateTimeString: string): void | Binds a DateTime value to the ECSQL parameter. | |
bindDouble(val: number): void | Binds a double value to the ECSQL parameter. | |
bindGuid(val: string): void | Binds an GUID value to the ECSQL parameter. | |
bindId(val: string): void | Binds an Id value to the ECSQL parameter. | |
bindIdSet(vector: string[]): void | Binds a set of Id strings to the ECSQL parameter. | |
bindInteger(val: string | number): void | Binds an integer value to the ECSQL parameter. | |
bindMember(memberName: string): ECSqlBinder | Gets the binder for the specified member of a struct parameter | |
bindNavigation(val: NavigationBindingValue): void | Binds a navigation property value to the ECSQL parameter. | |
bindNull(): void | Binds null to the ECSQL parameter. | |
bindPoint2d(val: Readonly<WritableXAndY>): void | Binds an Point2d value to the ECSQL parameter. | |
bindPoint3d(val: Readonly<WritableXYAndZ>): void | Binds an Point3d value to the ECSQL parameter. | |
bindRange3d(val: Readonly<WritableLowAndHighXYZ>): void | Binds a Range3d as a blob to the ECSQL parameter. | |
bindString(val: string): void | Binds an string to the ECSQL parameter. | |
bindStruct(val: object): void | Binds a struct property value to the ECSQL parameter. |
Defined in
- backend/src/ECSqlStatement.ts Line 397
Last Updated: 20 June, 2023