AzureBlobStorage Class
Deprecated in 3.x. Use @itwin/object-storage-oss
instead, see https://github.com/iTwin/object-storage for more details.
Beta
Extends
Methods
Name | Description | |
---|---|---|
constructor(credentials: AzureBlobStorageCredentials): AzureBlobStorage | ||
ensureContainer(name: string): Promise<void> | ||
obtainContainerUrl(id: CloudStorageContainerDescriptor, expiry: Date, clientIp?: string): CloudStorageContainerUrl | ||
upload(container: string, name: string, data: Uint8Array, options?: CloudStorageUploadOptions, metadata?: object): Promise<string> |
Inherited methods
Name | Inherited from | Description |
---|---|---|
download(_name: string): Promise<undefined | Readable> | CloudStorageService | |
initialize(): void | CloudStorageService | |
makeDescriptor(id: CloudStorageContainerDescriptor): { name: string, provider: CloudStorageProvider } Protected | CloudStorageService | |
terminate(): void | CloudStorageService |
Properties
Name | Type | Description | |
---|---|---|---|
id Readonly | Azure |
Defined in
Last Updated: 20 June, 2023