DateTimeTypeConverterBase Class
DateTime Type Converter.
Extends
Extended by
Implements
Methods
Name |
Description |
|
constructor(): DateTimeTypeConverterBase |
|
|
convertFromString(value: string): undefined | Date |
Converts a string to a primitive value |
|
convertFromStringWithOptions(value: string, options?: { T }): undefined | ConvertedPrimitives.Value | Promise<undefined | ConvertedPrimitives.Value> |
Default implementation just calls convertFromString with no options |
|
convertToString(value?: Value): string |
Converts a primitive value to a string |
|
convertToStringWithOptions(value?: Value, options?: { T }): string | Promise<string> |
Default implementation just calls convertToString with no options |
|
getTimeFormat(): TimeFormat ProtectedAbstract |
|
|
isEqualTo(valueA: Date, valueB: Date): boolean |
Determines if two primitive values are equal |
|
isGreaterThan(a: Date, b: Date): boolean |
Determines if a primitive values is greater than another primitive value |
|
isGreaterThanOrEqualTo(a: Date, b: Date): boolean |
Determines if a primitive values is greater than or equal to another primitive value |
|
isLessThan(a: Date, b: Date): boolean |
Determines if a primitive values is less than another primitive value |
|
isLessThanOrEqualTo(a: Date, b: Date): boolean |
Determines if a primitive values is less than or equal to another primitive value |
|
isNotEqualTo(valueA: Date, valueB: Date): boolean |
Determines if two primitive values are not equal |
|
sortCompare(valueA: Date, valueB: Date, _ignoreCase?: boolean): number |
Sort function for two primitive values |
|
isAlternateDateFormats(type: AlternateDateFormats): boolean Static |
|
|
isValidTimeDisplay(type: TimeDisplay): boolean Static |
|
|
Inherited methods
Name |
Inherited from |
Description |
convertFromStringToPropertyValue(value: string, propertyRecord?: PropertyRecord): Promise<PropertyValue> |
TypeConverter |
Converts a string with a property record to a property value |
convertPropertyToString(propertyDescription: PropertyDescription, value?: Value): string | Promise<string> |
TypeConverter |
Converts a value associated with a property description to a string |
isNotNull(value: Value): boolean |
TypeConverter |
Determines if a primitive value is not null or not undefined |
isNull(value: Value): boolean |
TypeConverter |
Determines if a primitive value is null or undefined |
Properties
Name |
Type |
Description |
|
isLessGreaterType Accessor ReadOnly |
boolean |
|
|
Inherited properties
Name |
Type |
Inherited from |
Description |
isBooleanType Accessor ReadOnly |
boolean |
TypeConverter |
Determines if the converter is for a boolean type |
isNullableType Accessor ReadOnly |
boolean |
TypeConverter |
Determines if the converter is for a nullable type |
isStringType Accessor ReadOnly |
boolean |
TypeConverter |
Determines if the converter is for a string type |
Defined in
Last Updated:
20 June, 2023