FilterableColumn Interface
Deprecated in 3.5. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.
Represents a column that is filterable.
Methods
Name | Description | |
---|---|---|
createSimpleFilterDescriptor(value: any, filterOperator: FilterOperator): OperatorValueFilterDescriptor | Allows the column to create a filter descriptor for use in the filter descriptor collection. | |
getDistinctValues(maximumValueCount?: number): Promise<DistinctValueCollection> | Gets the distinct values within the columns in the table. |
Properties
Name | Type | Description | |
---|---|---|---|
columnFilterDescriptor | ColumnFilterDescriptor | Gets the filter descriptor. | |
filterCaseSensitive | boolean | Determines if the filter is case-sensitive | |
filterMemberKey | string | Gets the member (key). | |
filterMemberType | string | Gets the member type. | |
filterableTable | FilterableTable | Gets the owning Table for this column. | |
isFilterActive | boolean | Determines if the filter for this column is active. | |
showDistinctValueFilters | boolean | Determines if the filter should show distinct values as a filter option | |
showFieldFilters | boolean | Determines if the filter should show field filter options |
Defined in
Last Updated: 20 June, 2023