PropertyGridModelSource Class
Controls property grid model. It is used to modify property grid model model and inform when the model changes.
Implements
Methods
Name | Description | |
---|---|---|
constructor(_gridFactory: IMutableGridItemFactory): PropertyGridModelSource | ||
getModel(): undefined | IPropertyGridModel | Returns property grid model. | |
modifyModel(callback: (model: IMutablePropertyGridModel) => void): void | Modifies property grid model using provided callback. | |
setPropertyData(data: PropertyData): void |
Properties
Name | Type | Description | |
---|---|---|---|
onModelChanged | PropertyGridModelChangeEvent | Event that is emitted every time property model is changed. |
Defined in
Last Updated: 20 June, 2023