IMutableGridItemFactory Interface
IMutableGridItemFactory interface for creating MutableGridItem objects
Implemented by
Methods
Name | Description | |
---|---|---|
createCategorizedProperty(record: PropertyRecord, parentSelectionKey: string, parentCategorySelectionKey: string, depth: number, overrideName?: string, overrideDisplayLabel?: string): IMutableCategorizedPropertyItem | ||
createGridCategory(category: PropertyCategory, recordsDict: CategoryRecordsDict, parentSelectionKey?: string, depth?: number): IMutableGridCategoryItem |
Defined in
- ui/components-react/src/components-react/propertygrid/internal/flat-items/MutableGridItemFactory.ts Line 21
Last Updated: 20 June, 2023