IMutableGridCategoryItem Interface
Data structure which describes methods and properties to be held by Mutable GridCategoryItems
Extends
Implemented by
Methods
Name | Description | |
---|---|---|
getChildCategories(): IMutableGridCategoryItem[] | Deprecated | |
getDescendantCategoriesAndSelf(): IMutableGridCategoryItem[] | Deprecated |
Inherited methods
Properties
Name | Type | Description | |
---|---|---|---|
derivedCategory | PropertyCategory | ||
isRootCategory | boolean | ||
name | string | ||
type | Category |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
depth Readonly | number | IMutableFlatPropertyGridItem | |
isExpanded | boolean | IMutableFlatPropertyGridItem | |
isLastInRootCategory | boolean | IMutableFlatPropertyGridItem | |
key Readonly | string | IMutableFlatPropertyGridItem | |
label Readonly | string | IMutableFlatPropertyGridItem | |
lastInNumberOfCategories | number | IMutableFlatPropertyGridItem | |
parentCategorySelectionKey Readonly | undefined | string | IMutableFlatPropertyGridItem | |
parentSelectionKey Readonly | undefined | string | IMutableFlatPropertyGridItem | |
selectionKey Readonly | string | IMutableFlatPropertyGridItem |
Defined in
- ui/components-react/src/components-react/propertygrid/internal/flat-items/MutableFlatGridItem.ts Line 187
Last Updated: 20 June, 2023