getContentDescriptor Method

Overloads
getContentDescriptor(_token, _options)  
getContentDescriptor(_token, _options, _displayType, _keys, _selection) Deprecated  

getContentDescriptor(_token, _options)

getContentDescriptor(_token: IModelRpcProps, _options: ContentDescriptorRpcRequestOptions): PresentationRpcResponse<undefined | DescriptorJSON>

Parameter Type Description
_token IModelRpcProps  
_options ContentDescriptorRpcRequestOptions  

Returns - PresentationRpcResponse<undefined | DescriptorJSON>



getContentDescriptor(_token, _options, _displayType, _keys, _selection)

Deprecated  Use an overload with ContentDescriptorRpcRequestOptions

getContentDescriptor(_token: IModelRpcProps, _options: ContentRpcRequestOptions, _displayType: string, _keys: KeySetJSON, _selection: undefined | SelectionInfo): PresentationRpcResponse<undefined | DescriptorJSON>

Parameter Type Description
_token IModelRpcProps  
_options ContentRpcRequestOptions  
_displayType string  
_keys KeySetJSON  
_selection undefined | SelectionInfo  

Returns - PresentationRpcResponse<undefined | DescriptorJSON>


Defined in

Last Updated: 11 June, 2024