DisplayStyleSettingsProps Interface
JSON representation of the settings associated with a DisplayStyleProps.
These settings are not stored directly as members of the DisplayStyleProps. Instead, they are stored
as members of jsonProperties.styles
.
see DisplayStyleSettings.
Properties
Name | Type | Description | |
---|---|---|---|
analysisFraction | undefined | number | A floating point value in [0..1] representing the animation state of this style's DisplayStyleSettingsProps.analysisStyle. | |
analysisStyle | undefined | AnalysisStyleProps | Settings controlling display of analytical models. | |
backgroundColor | undefined | number | The color displayed in the view background. | |
backgroundMap | undefined | BackgroundMapProps | Settings controlling display of map within views of geolocated models. | |
clipStyle | undefined | ClipStyleProps | Style applied by the view's ClipVector. | |
contextRealityModels | undefined | ContextRealityModelProps[] | ||
excludedElements | string | Id64Array | Ids of elements not to be displayed in the view. | |
mapImagery | undefined | MapImageryProps | Map Imagery. | |
modelOvr | undefined | DisplayStyleModelAppearanceProps[] | Overrides applied to the appearance of models in the view. | |
monochromeColor | undefined | number | The color used in monochrome mode. | |
monochromeMode | undefined | MonochromeMode | The style in which the monochrome color is applied. | |
planarClipOvr | undefined | DisplayStylePlanarClipMaskProps[] | Planar clip masks applied to reality models. | |
renderTimeline | undefined | string | The Id of a RenderTimeline element containing a RenderSchedule.Script that can be used to animate the view. | |
subCategoryOvr | undefined | DisplayStyleSubCategoryProps[] | Overrides applied to the appearances of subcategories in the view. | |
timePoint | undefined | number | The point in time reflected by the view, in UNIX seconds. | |
viewflags | undefined | ViewFlagProps | ||
whiteOnWhiteReversal | undefined | WhiteOnWhiteReversalProps |
Defined in
Last Updated: 11 June, 2024