DisplayStyleSettingsProps Interface
JSON representation of the settings associated with a DisplayStyleProps.
These settings are not stored directly as members of the DisplayStyleProps. Instead, they are stored
as members of jsonProperties.styles
.
see DisplayStyleSettings.
Properties
Name | Type | Description | |
---|---|---|---|
backgroundColor | undefined | ColorDefProps | The color displayed in the view background. | |
backgroundMap | undefined | BackgroundMapProps | Settings controlling display of map imagery within views of geolocated models. | |
contextRealityModels | undefined | ContextRealityModelProps[] | Contextual Reality Models | |
excludedElements | undefined | Id64String[] | List of IDs of excluded elements | |
monochromeColor | undefined | ColorDefProps | The color used in monochrome mode. | |
scheduleScript | undefined | RenderSchedule.ModelTimelineProps[] | Schedule script | Beta |
subCategoryOvr | undefined | DisplayStyleSubCategoryProps[] | Overrides applied to the appearances of subcategories in the view. | |
viewflags | undefined | ViewFlagProps |
Defined in
Last Updated: 13 June, 2024