UiFramework Class

Manages the Redux store, I18N service and iModel, Project and Login services for the ui-framework package.

Methods

Name Description
closeCursorMenu(): void Static   Beta  
dispatchActionToStore(type: string, payload: any, immediateSync: boolean = false): void Static    
getAccessToken(): AccessToken | undefined Static    
getAccudrawSnapMode(): SnapMode Static    
getActiveIModelId(): string Static    
getActiveSelectionScope(): string Static    
getAvailableSelectionScopes(): PresentationSelectionScope[] Static   Beta  
getColorTheme(): string Static   Beta  
getCursorMenuData(): CursorMenuData | undefined Static   Beta  
getDefaultIModelViewportControlId(): string | undefined Static    
getDefaultRulesetId(): string | undefined Static    
getDefaultViewId(): string | undefined Static    
getDefaultViewState(): ViewState | undefined Static    
getIModelConnection(): IModelConnection | undefined Static    
getIsUiVisible(): boolean Static   Beta  
getWidgetOpacity(): number Static   Beta  
initialize(store: Store<any>, i18n: I18N, oidcConfig?: OidcFrontendClientConfiguration | OidcDesktopClientConfiguration, frameworkStateKey?: string): Promise<any> Static Called by the app to initialize the UiFramework  
isMobile(): boolean Static   Beta  
openCursorMenu(menuData: CursorMenuData | undefined): void Static   Beta  
setAccessToken(accessToken: AccessToken | undefined, immediateSync: boolean = false): void Static   Deprecated  
setAccudrawSnapMode(snapMode: SnapMode): void Static    
setActiveIModelId(iModelId: string): void Static    
setActiveSelectionScope(selectionScopeId: string): void Static    
setColorTheme(theme: string): void Static   Beta  
setDefaultIModelViewportControlId(iModelViewportControlId: string, immediateSync: boolean = false): void Static    
setDefaultRulesetId(viewId: string, immediateSync: boolean = false): void Static    
setDefaultViewId(viewId: string, immediateSync: boolean = false): void Static    
setDefaultViewState(viewState: ViewState, immediateSync: boolean = false): void Static    
setIModelConnection(iModelConnection: IModelConnection | undefined, immediateSync: boolean = false): void Static    
setIsUiVisible(visible: boolean): void Static   Beta  
setWidgetOpacity(opacity: number): void Static   Beta  
terminate(): void Static Unregisters the UiFramework internationalization service namespace  

Properties

Name Type Description
backstageManager Accessor StaticReadOnly BackstageManager   Beta  
frameworkState Accessor StaticReadOnly FrameworkState | undefined The UiFramework state maintained by Redux Beta  
frameworkStateKey Accessor StaticReadOnly string   Beta  
i18n Accessor StaticReadOnly I18N The internationalization service created by the app.  
i18nNamespace Accessor StaticReadOnly string The internationalization service namespace.  
oidcClient Accessor Static IOidcFrontendClient | undefined   Beta  
onUiVisibilityChanged Static UiVisibilityChangedEvent Get Show Ui event. Beta  
pluginStatusBarItemsManager Accessor StaticReadOnly StatusBarItemsManager Get the StatusBarItemsManager used to manage status bar items provided by plugins. Beta  
statusBarManager Accessor StaticReadOnly StatusBarManager   Beta  
store Accessor StaticReadOnly Store<any> The Redux store  

Defined in

Last Updated: 13 June, 2024