remove Method

Removes favorite properties from scopes that there is info about.

remove(field: Field, projectId?: string, imodelId?: string): Promise<void>

Parameter Type Description
field Field Field that contains properties. If field contains multiple properties, all of them will be un-favorited.
projectId string Project Id to additionaly remove favorite properties from project scope, otherwise undefined.
imodelId string iModel Id to additionaly remove favorite properties from iModel scope, otherwise undefined. The projectId must be specified if iModelId is specified.

Returns - Promise<void>

Defined in

Last Updated: 13 June, 2024