ContentSpecificationBase Interface
Base interface for all ContentSpecification implementations. Not
meant to be used directly, see ContentSpecification
.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
priority | undefined | number | Defines the order in which specifications are evaluated and executed. | |
relatedInstances | undefined | RelatedInstanceSpecification[] | Specifications for joining related instances | |
showImages | undefined | boolean | Should each content record be assigned an image id | |
specType | ContentSpecificationTypes | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
calculatedProperties | undefined | CalculatedPropertiesSpecification[] | ContentModifiersList | Specifications for including calculated properties |
propertiesDisplay | undefined | PropertiesDisplaySpecification[] | ContentModifiersList | Specifications for customizing property display by hiding / showing them |
propertyCategories | undefined | PropertyCategorySpecification[] | ContentModifiersList | Specifications for custom categories. |
propertyEditors | undefined | PropertyEditorsSpecification[] | ContentModifiersList | Specifications for assigning property editors |
propertyOverrides | undefined | PropertySpecification[] | ContentModifiersList | Specifications for various property overrides. |
relatedProperties | undefined | RelatedPropertiesSpecification[] | ContentModifiersList | Specifications for including properties of related instances |
Defined in
Last Updated: 13 June, 2024