processModel Method

Cause the model container, contents, and sub-models to be exported from the source iModel and imported into the target iModel.

processModel(sourceModeledElementId: Id64String): void

note This method is called from IModelTransformer.processChanges and IModelTransformer.processAll, so it only needs to be called directly when processing a subset of an iModel.

Parameter Type Description
sourceModeledElementId Id64String Import this Model from the source IModelDb.

Returns - void

Defined in

Last Updated: 13 June, 2024