processChanges Method

Export changes from the source iModel and import the transformed entities into the target iModel. Inserts, updates, and deletes are determined by inspecting the changeset(s).

processChanges(requestContext: AuthorizedClientRequestContext, startChangeSetId?: GuidString): Promise<void>

Parameter Type Description
requestContext AuthorizedClientRequestContext The request context
startChangeSetId GuidString Include changes from this changeset up through and including the current changeset.
If this parameter is not provided, then just the current changeset will be exported.

Returns - Promise<void>

Defined in

Last Updated: 13 June, 2024