processElement Method

Cause the specified Element and its child Elements (if applicable) to be exported from the source iModel and imported into the target iModel.

processElement(sourceElementId: Id64String): void

note This method is called from IModelTransformer.processChanges and IModelTransformer.processAll, so it only needs to be called directly when processing a subset of an iModel.

Parameter Type Description
sourceElementId Id64String Identifies the Element from the source iModel to import.

Returns - void

Defined in

Last Updated: 13 June, 2024