HiliteSetProvider Class
Presentation-based provider which uses presentation ruleset to determine
what HiliteSet
should be hilited in the graphics viewport based on the
supplied KeySet
.
Methods
Name | Description | |
---|---|---|
getHiliteSet(selection: Readonly<KeySet>): Promise<HiliteSet> | Get hilite set for instances and/or nodes whose keys are specified in the | |
create(props: HiliteSetProviderProps): HiliteSetProvider Static | Create a hilite set provider for the specified iModel. |
Defined in
Last Updated: 20 June, 2023