Presentation Class
Static class used to statically set up Presentation library for the frontend. Basically what it does is:
- Create a singleton PresentationManager instance
- Create a singleton SelectionManager instance
- Create a singleton FavoritePropertiesManager] instance
Methods
Name | Description | |
---|---|---|
initialize(props?: PresentationProps): Promise<void> Static | Initializes Presentation library for the frontend. | |
terminate(): void Static | Terminates Presentation library frontend. |
Properties
Name | Type | Description | |
---|---|---|---|
favoriteProperties Accessor StaticReadOnly | FavoritePropertiesManager | The singleton FavoritePropertiesManager | |
localization Accessor StaticReadOnly | Localization | The localization manager used by Presentation frontend. | |
presentation Accessor StaticReadOnly | PresentationManager | The singleton PresentationManager | |
selection Accessor StaticReadOnly | SelectionManager | The singleton SelectionManager |
Defined in
Last Updated: 20 June, 2023