viewWithUnifiedSelection Function
A HOC component that adds unified selection functionality to the supplied viewport component.
viewWithUnifiedSelection<P extends ViewportProps>(ViewportComponent: ComponentType<P>): React.ComponentType<P & ViewWithUnifiedSelectionProps>
Parameter | Type | Description |
---|---|---|
ViewportComponent | ComponentType<P> |
Returns - React.ComponentType<P & ViewWithUnifiedSelectionProps>
Defined in
Last Updated: 20 June, 2023