ViewportProps Interface
Properties for ViewportComponent component.
Extends
Methods
Name | Description | |
---|---|---|
getViewOverlay(viewport: ScreenViewport): ReactNode Optional | ||
onContextMenu(e: MouseEvent<Element, MouseEvent>): boolean Optional | ||
viewportRef(v: ScreenViewport): void Optional | Function to get a reference to the ScreenViewport |
Properties
Name | Type | Description | |
---|---|---|---|
controlId | undefined | string | controlId for this content component @internal | |
imodel | IModelConnection | IModel to display | |
viewDefinitionId | undefined | string | Id of a default view definition to load as a starting point | |
viewState | undefined | ViewStateProp | ViewState to use as a starting point |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023