tableWithUnifiedSelection Function
Deprecated in 3.x. Based on Table component which is deprecated
A HOC component that adds unified selection functionality to the supplied table component.
Note: it is required for the table to use PresentationTableDataProvider
tableWithUnifiedSelection<P extends TableProps>(TableComponent: ComponentType<P>): React.ComponentType<P & TableWithUnifiedSelectionProps>
Parameter | Type | Description |
---|---|---|
TableComponent | ComponentType<P> |
Returns - React.ComponentType<P & TableWithUnifiedSelectionProps>
Defined in
Last Updated: 20 June, 2023