PresentationPropertyDataProviderProps Interface
Properties for creating a PresentationPropertyDataProvider
instance.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
disableFavoritesCategory | undefined | boolean | If true, additional 'favorites' category is not created. | Beta |
enableContentAutoUpdate | undefined | boolean | Auto-update property data when ruleset, ruleset variables or data in the iModel changes. | |
imodel | IModelConnection | IModelConnection to use for requesting property data. | |
ruleset | string | Ruleset | Id of the ruleset to use when requesting properties or a ruleset itself. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
ruleDiagnostics | undefined | { handler: ClientDiagnosticsHandler, severity?: DiagnosticsLoggerSeverity } | DiagnosticsProps | Settings for capturing rule diagnostics. |
Defined in
Last Updated: 20 June, 2023