PresentationInstanceFilterDialogProps Interface
Beta
Props for PresentationInstanceFilterDialog component.
Extends
Methods
Name |
Description |
|
filterResultCountRenderer(filter?: PresentationInstanceFilterInfo): ReactNode Optional |
Renderer that renders count of results for currently built filter. |
|
onApply(filter: PresentationInstanceFilterInfo): void |
Callback that is invoked when 'Apply' button is clicked. |
|
onClose(): void |
Callback that is invoked when 'Close' button is clicked or dialog is closed. |
|
Properties
Inherited properties
Name |
Type |
Inherited from |
Description |
imodel |
IModelConnection |
Omit |
iModel connection to pull data from. |
initialFilter |
undefined | PresentationInstanceFilterInfo |
Omit |
Initial filter that will be show when component is mounted. |
ruleGroupDepthLimit |
undefined | number |
Omit |
Specifies how deep rule groups can be nested. |
Defined in
Last Updated:
20 June, 2023