ContentDataProviderProps Interface
Properties for creating a ContentDataProvider
instance.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
displayType | string | The content display type which this provider is going to load data for. | |
enableContentAutoUpdate | undefined | boolean | Auto-update content when ruleset, ruleset variables or data in the iModel changes. | |
imodel | IModelConnection | IModel to pull data from. | |
pagingSize | undefined | number | Paging size for obtaining content records. | |
ruleset | string | Ruleset | Id of the ruleset to use when requesting content or a ruleset itself. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
ruleDiagnostics | undefined | { handler: ClientDiagnosticsHandler, severity?: DiagnosticsLoggerSeverity } | DiagnosticsProps | Settings for capturing rule diagnostics. |
Defined in
Last Updated: 20 June, 2023