SortingRuleBase Interface
Sorting rules provide a way to either disable sorting or sort instances by specific properties.
see Sorting rule reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
class | undefined | SingleSchemaClassSpecification | Specifies ECClass whose ECInstances should be sorted. | |
condition | undefined | string | Defines a condition which needs to be met in order for the rule to be used. | |
isPolymorphic | undefined | boolean | Specifies that SortingRuleBase.class attribute defined in this rule should be handled polymorphically. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled | undefined | boolean | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority | undefined | number | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas | undefined | RequiredSchemaSpecification[] | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
ruleType | "Content" | "DefaultPropertyCategoryOverride" | "ContentModifier" | "CheckBox" | "ExtendedData" | "Grouping" | "ImageIdOverride" | "InstanceLabelOverride" | "LabelOverride" | "RootNodes" | "ChildNodes" | "PropertySorting" | "DisabledSorting" | "NodeArtifacts" | "StyleOverride" | RuleBase | Used for serializing to JSON. |
Defined in
Last Updated: 20 June, 2023