PropertySortingRule Interface
Rule to configure sorting for certain ECInstances in the hierarchy and/or content. It is possible to configure different sorting for different types of ECInstances.
see Property sorting rule reference documentation section
Extends
Properties
Name | Type | Description | |
---|---|---|---|
propertyName | string | Specifies name of the property which should be used for sorting. | |
ruleType | "PropertySorting" | Used for serializing to JSON. | |
sortAscending | undefined | boolean | Specifies whether instances should be sorted in ascending order or descending. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
class | undefined | SingleSchemaClassSpecification | SortingRuleBase | Specifies ECClass whose ECInstances should be sorted. |
condition | undefined | string | SortingRuleBase | Defines a condition which needs to be met in order for the rule to be used. |
isPolymorphic | undefined | boolean | SortingRuleBase | Specifies that SortingRuleBase.class attribute defined in this rule should be handled polymorphically. |
onlyIfNotHandled | undefined | boolean | SortingRuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority | undefined | number | SortingRuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas | undefined | RequiredSchemaSpecification[] | SortingRuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 20 June, 2023