NavigationRuleBase Interface
Base class for all NavigationRule implementations.
see Hierarchies reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
condition | undefined | string | Defines a condition which needs to be met in order for the rule to be used. | |
customizationRules | undefined | CustomizationRule[] | A list of customization rules that | |
specifications | undefined | ChildNodeSpecification[] | A list of hierarchy specifications that define what nodes are going to be returned. | |
stopFurtherProcessing | undefined | boolean | Stop processing rules that have lower priority. | |
subConditions | undefined | SubCondition[] | A list of sub-rules which share placement attributes and |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled | undefined | boolean | RuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority | undefined | number | RuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas | undefined | RequiredSchemaSpecification[] | RuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
ruleType | "Content" | "DefaultPropertyCategoryOverride" | "ContentModifier" | "CheckBox" | "ExtendedData" | "Grouping" | "ImageIdOverride" | "InstanceLabelOverride" | "LabelOverride" | "RootNodes" | "ChildNodes" | "PropertySorting" | "DisabledSorting" | "NodeArtifacts" | "StyleOverride" | RuleBase | Used for serializing to JSON. |
Defined in
Last Updated: 20 June, 2023