CustomNodeSpecification Interface
Returns a static custom-defined node that's not based on an ECInstance.
see Custom node specification reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
description | undefined | string | Specifies the value of Node.description property, which is a string that may | |
imageId | undefined | string | Specifies node's image ID. | |
label | string | Specifies node label. | |
specType | "CustomNode" | Used for serializing to JSON. | |
type | string | Specifies node type, which is assigned to node's key. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
doNotSort | undefined | boolean | ChildNodeSpecificationBase | Suppress sorting of nodes returned by this specification. |
hasChildren | "Always" | "Never" | "Unknown" | ChildNodeSpecificationBase | This attribute allows telling the engine that nodes created by this specification always or never have children. |
hideExpression | undefined | string | ChildNodeSpecificationBase | When specified ECExpression evaluates |
hideIfNoChildren | undefined | boolean | ChildNodeSpecificationBase | Specifies whether nodes created through this specification should be hidden if they have no child nodes. |
hideNodesInHierarchy | undefined | boolean | ChildNodeSpecificationBase | When true , instances nodes produced by this specification are omitted and their children appear one |
nestedRules | undefined | ChildNodeRule[] | ChildNodeSpecificationBase | Specifications of nested child node rules that |
priority | undefined | number | ChildNodeSpecificationBase | Controls the order in which specifications are handled — specification with higher priority value is |
relatedInstances | undefined | RelatedInstanceSpecification[] | ChildNodeSpecificationBase | Specifications of related instances that can be used |
suppressSimilarAncestorsCheck | undefined | boolean | ChildNodeSpecificationBase | Specifies whether similar ancestor nodes' checking should be suppressed when creating nodes based on this |
Defined in
Last Updated: 20 June, 2023