constructor Method
Creates an instance of PropertiesField.
PropertiesField(category: CategoryDescription, name: string, label: string, description: TypeDescription, isReadonly: boolean, priority: number, properties: Property[], editor?: EditorDescription, renderer?: RendererDescription): PropertiesField
Parameter | Type | Description |
---|---|---|
category | CategoryDescription | Category information |
name | string | Unique name |
label | string | Display label |
description | TypeDescription | |
isReadonly | boolean | Are values in this field read-only |
priority | number | Priority of the field |
properties | Property[] | A list of properties this field is created from |
editor | EditorDescription | Property editor used to edit values of this field |
renderer | RendererDescription | Property renderer used to render values of this field |
Returns - PropertiesField
Defined in
Last Updated: 20 June, 2023