constructor Method
Creates an instance of Field.
Field(category: CategoryDescription, name: string, label: string, type: TypeDescription, isReadonly: boolean, priority: number, editor?: EditorDescription, renderer?: RendererDescription): Field
Parameter | Type | Description |
---|---|---|
category | CategoryDescription | Category information |
name | string | Unique name |
label | string | Display label |
type | TypeDescription | Description of this field's values data type |
isReadonly | boolean | Are values in this field read-only |
priority | number | Priority of the field |
editor | EditorDescription | Property editor used to edit values of this field |
renderer | RendererDescription | Property renderer used to render values of this field |
Returns - Field
Defined in
Last Updated: 20 June, 2023