updateFromToLocation MethodStatic

Update an existing LinearlyReferencedFromToLocation aspect within the iModel.

updateFromToLocation(iModel: IModelDb, linearlyLocatedElementId: string, linearLocationProps: LinearlyReferencedFromToLocationProps, aspectId?: string): void

throws IModelError

Parameter Type Description
iModel IModelDb The iModel to update.
linearlyLocatedElementId string The Id of the owning Linearly Located Element.
linearLocationProps LinearlyReferencedFromToLocationProps The properties to use to update the LinearlyReferencedFromToLocation aspect.
aspectId string The Id of the aspect to update. If not known, the first aspectId will be looked-up.

Returns - void

Defined in

Last Updated: 20 June, 2023