updateAtLocation MethodStatic
Update an existing LinearlyReferencedAtLocation aspect within the iModel.
updateAtLocation(iModel: IModelDb, linearlyLocatedElementId: string, linearLocationProps: LinearlyReferencedAtLocationProps, aspectId?: string): void
throws IModelError
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The iModel to update. |
linearlyLocatedElementId | string | The Id of the owning Linearly Located Element. |
linearLocationProps | LinearlyReferencedAtLocationProps | The properties to use to update the LinearlyReferencedAtLocation aspect. |
aspectId | string | The Id of the aspect to update. If not known, the first aspectId will be looked-up. |
Returns - void
Defined in
Last Updated: 20 June, 2023