getFromToLocation MethodStatic
Query for the single LinearlyReferenced FromToLocation aspect owned by the specified LinearlyLocated Element. If more than one aspect is expected, use LinearlyLocated.getFromToLocations instead.
getFromToLocation(iModel: IModelDb, linearlyLocatedElementId: string): undefined | LinearlyReferencedFromToLocation
throws IModelError
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The iModel to query from. |
linearlyLocatedElementId | string | The id of the LinearlyLocated Element to query about. |
Returns - undefined | LinearlyReferencedFromToLocation
Returns an LinearlyReferencedFromToLocation or undefined is none is found.
Defined in
Last Updated: 20 June, 2023