ILinearElementProvidedBySource Class
Beta
Relationship associating Linear-Elements with the elements they came from.
Extends
Methods
Name | Description | |
---|---|---|
constructor(sourceId: string, relClassName: string = ILinearElementProvidedBySource.classFullName): ILinearElementProvidedBySource |
Inherited methods
Name | Inherited from | Description |
---|---|---|
toJSON(): RelatedElementProps | RelatedElement | |
fromJSON(json?: RelatedElementProps): undefined | RelatedElement Static | RelatedElement | |
idFromJson(json: any): string Static | RelatedElement | Accept the value of a navigation property that might be in the shortened format of just an id or might be in the full RelatedElement format. |
Properties
Name | Type | Description | |
---|---|---|---|
classFullName Static | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
id Readonly | string | RelatedElement | The Id of the element to which this element is related. |
none StaticReadonly | RelatedElement | RelatedElement | Used to null out an existing navigation relationship. |
relClassName Readonly | undefined | string | RelatedElement | The full className of the relationship class. |
Defined in
Last Updated: 20 June, 2023