TimelineDataProvider Interface
Interface for a timeline data provider class
Methods
Name | Description | |
---|---|---|
getSettings(): PlaybackSettings | ||
loadTimelineData(): Promise<boolean> | Async call to load milestone and settings data | |
updateSettings(settings: PlaybackSettings): void | Called to save the playback settings |
Properties
Name | Type | Description | |
---|---|---|---|
animationFraction | undefined | number | Current animation fraction from 0.0 to 1.0 | |
duration | number | Called to get the duration of the Playback. | |
end | undefined | Date | End date for entire timeline | |
id | string | uniqueId of provider | |
initialDuration | number | Called to get the initial scrubber location. | |
loop | boolean | If true the playback will continuously loop. | |
onAnimationFractionChanged | undefined | AnimationFractionChangeHandler | Called when the an internal process has defined the playback settings and the UI needs to be updated | |
onPlaybackSettingChanged | undefined | PlaybackSettingsChangeHandler | Called when an internal process has defined the playback settings and the UI needs to be updated | |
start | undefined | Date | Starting date for entire timeline | |
supportsTimelineAnimation | boolean | returns true if the provider has timeline animation data available | |
viewId | string | view id when viewport is initially assigned | |
viewport | undefined | ScreenViewport | viewport to show animation |
Defined in
Last Updated: 20 June, 2023