QuantityNumberInputProps Interface
Beta
Properties for the QuantityNumberInput component
Extends
- Omit<InputProps, "value" | "min" | "max" | "step" | "onFocus" | "onChange">
Methods
Name | Description | |
---|---|---|
onChange(value: number): void Optional | Function to call when the quantity value is changed. |
Properties
Name | Type | Description | |
---|---|---|---|
containerClassName | undefined | string | CSS class name for the QuantityNumberInput component container div | |
max | undefined | number | number or function defaults to Number.MAX_SAFE_INTEGER | |
min | undefined | number | number or function Number.MIN_SAFE_INTEGER | |
persistenceValue | undefined | number | Initial magnitude in 'persistence' units. | |
quantityType | QuantityTypeArg | Type of quantity being input. | |
ref | undefined | Ref<HTMLInputElement> | Provides ability to return reference to HTMLInputElement | |
showTouchButtons | undefined | boolean | if true up/down buttons are shown larger and side by side | |
snap | undefined | boolean | Set to true to "snap" to the closest step value while incrementing or decrementing (up/down buttons or arrow keys). | |
step | undefined | StepFunctionProp | increment step value used while incrementing or decrementing (up/down buttons or arrow keys) defaults to 1. |
Defined in
Last Updated: 20 June, 2023