ColorPickerPopupProps Interface
Properties for the ColorPickerPopup React component
Extends
- ButtonHTMLAttributes<HTMLButtonElement>
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
captureClicks | undefined | boolean | If true, don't propagate clicks out of the ColorPicker | |
colorDefs | undefined | ColorDef[] | Preset colors. | |
colorInputType | "hsl" | "rgb" | "hex" | If set show input values | |
disabled | undefined | boolean | Disabled or not | |
hideCloseButton | undefined | boolean | If true, don't show close button at top | |
initialColor | ColorDef | Current color | |
onClose | undefined | (colorValue: ColorDef) => void | ||
onColorChange | undefined | (newColor: ColorDef) => void | ||
popupPosition | undefined | RelativePosition | popup position. | |
readonly | undefined | boolean | Readonly or not, color displayed on button but button will not trigger pop-up | |
ref | undefined | Ref<HTMLButtonElement> | Provides ability to return reference to HTMLButtonElement | |
showCaret | undefined | boolean | If true show up/down caret next to color |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 20 June, 2023