SectionMarkerSet Class
A MarkerSet containing SectionMarkers identifying SectionDrawingLocations within a spatial view. Typically used indirectly via HyperModelingDecorator.
Extends
Methods
Name | Description | |
---|---|---|
constructor(viewport: ScreenViewport, markers: SectionMarker[]): SectionMarkerSet | Constructor | |
findMarkerById(sectionDrawingLocationId: string): undefined | SectionMarker | Find the SectionMarker corresponding to the specified SectionDrawingLocation Id. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
addDecoration(context: DecorateContext): void | MarkerSet | This method should be called from decorate. |
changeViewport(viewport: ScreenViewport): void | MarkerSet | Change the ScreenViewport for this MarkerSet. |
getMinScaleViewW(vp: Viewport): number | MarkerSet | Get weight value limit establishing the distance from camera for the back of view scale factor. |
markDirty(): void | MarkerSet | Indicate that this MarkerSet has been changed and is now dirty. |
Properties
Name | Type | Description | |
---|---|---|---|
minimumClusterSize | number | ||
viewport Accessor ReadOnly | ScreenViewport | The viewport in which the markers are to be displayed. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
clusterRadius Protected | number | MarkerSet | The radius (in pixels) representing the distance between the screen X,Y positions of two Markers to be clustered. |
markers Accessor ReadOnly | Set<T> | MarkerSet | The set of Markers in this MarkerSet. Add your Markers into this. |
Defined in
- hypermodeling/src/SectionMarkers.ts Line 169
Last Updated: 20 June, 2023