createSectionGraphicsProvider Function
Creates a TiledGraphicsProvider that can be associated with a Viewport to display 2d section graphics and annotations in the context of a SpatialViewState.
Typically used indirectly via HyperModelingDecorator.
createSectionGraphicsProvider(state: SectionDrawingLocationState): Promise<TiledGraphicsProvider>
see HyperModelingDecorator.toggleAttachment to activate section graphics for a given SectionMarker.
Parameter | Type | Description |
---|---|---|
state | SectionDrawingLocationState | The section drawing location specifying which section drawing to display. |
Returns - Promise<TiledGraphicsProvider>
A provider suitable for passing to Viewport.addTiledGraphicsProvider.
Defined in
Last Updated: 20 June, 2023