TileMemoryBreakdown Class
Beta
Breaks down the GPU memory allocated to tiles into categories displayed in two panes. The left-hand pane obtains its information from TileAdmin, displaying the number of selected and unselected tiles that are consuming graphics memory along with the amount of memory consumed. The right-hand pane computes its information from the set of all TileTrees, broken down into groups:
- "Selected" - tiles that have been selected for display in at least one viewport.
- "Ancestors" - tiles not selected for display, but have descendents selected for display.
- "Descendants" - tiles not selected for display, but have ancestors selected for display.
- "Orphans" - tiles not selected for display that have no ancestors nor descendants selected for display.
- "Total" - totals of the above categories.
Each row of data shows (number of tiles) Group Name: amount of memory consumed by group
.
The number of tiles in each group includes only those tiles that are consuming a non-zero amount of GPU memory.
The widget includes a checkbox to toggle tracking and display of these statistics.
Methods
Name | Description | |
---|---|---|
constructor(parent: HTMLElement): TileMemoryBreakdown | Construct a new breakdown widget as a child of the specified parent element. | |
dispose(): void |
Defined in
Last Updated: 20 June, 2023