SourceAspectIdFromElementIdTool Class
Beta
Given a source aspect Id, output the Id of the corresponding element in the iModel. A "source aspect Id" is a string that identifies an object (such as an element) in the source document from which the iModel originated. For example, if the iModel was produced by the MicroStation bridge, the source aspect Id is usually a V8 element Id. Arguments:
id=elementId
whereelementId
is the numeric Id of the element of interest (e.g.,0x13a6c
; decimal notation is also permitted).copy=0|1
where1
indicates the source aspect Id should be copied to the clipboard. The command outputs to the IModelApp.notifications the corresponding source aspect Id, or "NOT FOUND".
Extends
Methods
Name | Description | |
---|---|---|
constructor(..._args: any[]): SourceAspectIdFromElementIdTool | ||
getECSql(queryId: string): string Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
parseAndRun(...keyinArgs: string[]): Promise<boolean> | SourceAspectIdTool | |
run(idToQuery?: string, copyToClipboard?: boolean): Promise<boolean> | SourceAspectIdTool | |
register(namespace?: string): void Static | SourceAspectIdTool | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
toolId Static | string | The unique string that identifies this tool. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
description Accessor ReadOnly | string | SourceAspectIdTool | Get the localized description string from this Tool's class |
description Accessor StaticReadOnly | string | SourceAspectIdTool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, SourceAspectIdTool.flyover is returned. |
englishKeyin Accessor StaticReadOnly | string | SourceAspectIdTool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor ReadOnly | string | SourceAspectIdTool | Get the localized flyover string from this Tool's class |
flyover Accessor StaticReadOnly | string | SourceAspectIdTool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, SourceAspectIdTool.keyin is returned. |
hidden Static | boolean | SourceAspectIdTool | If true, this Tool will not appear in the list from getToolList. |
iconSpec Accessor ReadOnly | string | SourceAspectIdTool | Get the iconSpec from this Tool's class. |
iconSpec Static | string | SourceAspectIdTool | The icon for this Tool. |
keyin Accessor ReadOnly | string | SourceAspectIdTool | Get the localized keyin string from this Tool's class |
keyin Accessor StaticReadOnly | string | SourceAspectIdTool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
maxArgs Accessor StaticReadOnly | number | SourceAspectIdTool | |
minArgs Accessor StaticReadOnly | number | SourceAspectIdTool | |
namespace Static | string | SourceAspectIdTool | The namespace that provides localized strings for this Tool. |
toolId Accessor ReadOnly | string | SourceAspectIdTool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
Defined in
Last Updated: 20 June, 2023