constructor Method

Initializes a new FormatDiagnosticReporter

LoggingDiagnosticReporter(suppressions?: Map<string, string[]>, localization?: Localization): LoggingDiagnosticReporter

Parameter Type Description
suppressions Map<string, string[]> A Map where the key is a schema full name and the value is collection of diagnostic codes to suppress.
localization Localization The Localization instance to use to translate validation messages.

Returns - LoggingDiagnosticReporter

Last Updated: 20 June, 2023