resumeTransformation MethodStatic
Return a new transformer instance with the same remappings state as saved from a previous IModelTransformer.saveStateToFile call. This allows you to "resume" an iModel transformation, you will have to call IModelTransformer.processChanges/IModelTransformer.processAll again but the remapping state will cause already mapped elements to be skipped. To "resume" an iModel Transformation you need:
- the sourceDb at the same changeset
- the same targetDb in the state in which it was before
resumeTransformation<SubClass extends (...a: any[]) => IModelTransformer>(this: SubClass, statePath: string, ...constructorArgs: ConstructorParameters<SubClass>): InstanceType<SubClass>
note custom transformers with custom state may need to override this method in order to handle loading their own custom state somewhere
Parameter | Type | Description |
---|---|---|
this | SubClass | |
statePath | string | the path to the serialized state of the transformer, use IModelTransformer.saveStateToFile to get this from an existing transformer instance |
...constructorArgs | ConstructorParameters<SubClass> | remaining arguments that you would normally pass to the Transformer subclass you are using, usually (sourceDb, targetDb) |
Returns - InstanceType<SubClass>
Defined in
- transformer/src/IModelTransformer.ts Line 1396
Last Updated: 20 June, 2023