onTransformRelationship MethodProtected
Transform the specified sourceRelationship into RelationshipProps for the target iModel.
onTransformRelationship(sourceRelationship: Relationship): RelationshipProps
note A subclass can override this method to provide custom transform behavior.
Parameter | Type | Description |
---|---|---|
sourceRelationship | Relationship | The Relationship from the source iModel to be transformed. |
Returns - RelationshipProps
RelationshipProps for the target iModel.
Defined in
- transformer/src/IModelTransformer.ts Line 1068
Last Updated: 20 June, 2023