onTransformElement Method
Transform the specified sourceElement into ElementProps for the target iModel.
onTransformElement(sourceElement: Element): ElementProps
note A subclass can override this method to provide custom transform behavior.
note This can be called more than once for an element in arbitrary order, so it should not have side-effects.
Parameter | Type | Description |
---|---|---|
sourceElement | Element | The Element from the source iModel to transform. |
Returns - ElementProps
ElementProps for the target iModel.
Defined in
- transformer/src/IModelTransformer.ts Line 577
Last Updated: 20 June, 2023