detectElementDeletes Method
Detect Element deletes using ExternalSourceAspects in the target iModel and a brute force comparison against Elements in the source iModel.
detectElementDeletes(): Promise<void>
see IModelTransformer.processChanges
note This method is called from IModelTransformer.processAll and is not needed by IModelTransformer.processChanges, so it only needs to be called directly when processing a subset of an iModel.
throws IModelError If the required provenance information is not available to detect deletes.
Returns - Promise<void>
Defined in
- transformer/src/IModelTransformer.ts Line 548
Last Updated: 20 June, 2023