onInsertElement MethodProtected
Create a new Element from the specified ElementProps and insert it into the target iModel.
onInsertElement(elementProps: ElementProps): string
note A subclass may override this method to customize insert behavior but should call super.onInsertElement
.
Parameter | Type | Description |
---|---|---|
elementProps | ElementProps |
Returns - string
The Id of the newly inserted Element.
Defined in
- transformer/src/IModelImporter.ts Line 221
Last Updated: 20 June, 2023