importElementMultiAspects Method
Import the collection of ElementMultiAspects into the target iModel.
importElementMultiAspects(aspectPropsArray: ElementAspectProps[], filterFunc: (a: ElementMultiAspect) => boolean = ...): string[]
note For insert vs. update reasons, it is important to process all ElementMultiAspects owned by an Element at once since we don't have aspect-specific provenance.
Parameter | Type | Description |
---|---|---|
aspectPropsArray | ElementAspectProps[] | The ElementMultiAspects to import |
filterFunc | (a: ElementMultiAspect) => boolean | Optional filter func that is used to exclude target ElementMultiAspects that were added during iModel transformation from the update detection logic. |
Returns - string[]
the array of ids of the resulting ElementMultiAspects, in the same order of the aspectPropsArray parameter
Defined in
- transformer/src/IModelImporter.ts Line 319
Last Updated: 20 June, 2023