IconHelper Class
Icon Helper Class used to store the data needed to generate an
Methods
Name | Description | |
---|---|---|
constructor(): IconHelper | ||
getIconData(iconSpec: IconSpec, internalData?: Map<string, any>): string | ConditionalStringValue Static | Returns an icon definition that can be stored in an abstract item definition. | |
getIconReactNode(icon: ReactNode | ConditionalStringValue, internalData?: Map<string, any>): ReactNode Static | Returns an |
Properties
Name | Type | Description | |
---|---|---|---|
reactIconKey Accessor StaticReadOnly | string |
Defined in
Last Updated: 20 June, 2023